Bug Reports / Nefsis & automatic Proxy configuration dosen´t work
<< < > >>
Reply to this Thread
3/10/2009 1:06:55 AM Reply with Quote

Hello,
i´m new to nefsis. we started to use Nefsis for Videoconferencing.
Now we run into a problem. In our network, we use automatic proxy configuration to provide for our "heavy travel" users an easy way to connet to the Internet on other locations.
All Browser settings are configured to use the web proxy autodiscover protocol (~250 users)
When we switch in the connection settings to "Automatic - Use my web browsers settings", the nefsis client isn´t using the wpad-script to get the proxy configuration and the connection could not be esthablished.
Entering the proxy by hand works perfectly.

Any known issues on this ?

3/10/2009 9:08:04 AM Reply with Quote
nefsisDiagInfo.exe 

We are not aware of any issues with WPAD, but if you could provide us with some information regarding your proxy configuration that would assist in determining what is causing the problem.

Is WPAD configured through DHCP or DNS?

What type of proxy server are you using?

What is your default browser on the workstation, and has this browser been configured to use the proxy?

Are the travelling users using a VPN to connect back to your home office?

Additionally, we would like you to enable XML logging in the affected Nefsis client(s). Follow these steps to enable XML logging:

Enabling XML logging in the client will allow the Nefsis client to log all communications between the client and the Nefsis cloud. This information is very useful for troubleshooting issues with the Nefsis tray application. Note that after the issue is resolved, XML logging should be disabled or the log file will grow very large in size.

To enable XML logging:

1. Launch the Nefsis tray application.

2. Log in to Nefsis.

3. Click on the Nefsis application button ( green 'N' in the upper left corner).

4. Click on the 'Settings' button at the bottom of the menu.

5. Under 'General settings' check the box labeled 'XML Logging'

6. Click on the 'OK' button.

Once you have done this, exit Nefsis completely and restart the client. Configure the client to use the browser's proxy settings and attempt to connect.

If the connection attempt fails, please run the executable file I have attached to this post on the client workstation. This will gather various system information about the workstation into a single folder on the desktop called Nefsis_Support_Info. Please email the contents of this folder to customercare@nefsis.com so that we may review the information.

3/12/2009 2:06:34 AM Reply with Quote

Ok, here we go:
- WPAD is configured in DNS, The 252-WPAD-Option is defined in DHCP Scope Options
- here we are using a squid proxy running on Linux (2.5.STABLE9)
- IE6 & IE7 are the default browsers on client workstations
- the travelling users are connected with VPN (Aventail), Corporate Network (MPLS) or direct internet connection
- XML Log looks like this:

PC (5.0.0.222): [12.03.2009 08:36:02]
http://www.nefsis.com/queryaccesspoints.aspx
<?xml version="1.0" encoding="UTF-8"?>
<command></command>

ERROR: LastSocketError=10060

PC (5.0.0.222): [12.03.2009 08:36:28]
http://www.nefsis.com/queryaccesspoints.aspx
<?xml version="1.0" encoding="UTF-8"?>
<command></command>

ERROR: LastSocketError=10060

(using to above URL with automatic proxy configuration shows me the Servers from the "Nefsis cloud")


- Diag File is send to CustomerCare..

3/12/2009 9:06:25 AM Reply with Quote

Thank you for the update Ulf. We'll be reviewing the information and testing a similar configuration.

3/17/2009 8:06:08 AM Reply with Quote

any news on that issue ?

3/17/2009 8:15:50 AM Reply with Quote

We have looked into the issue and found some problems with WPAD in our software. We plan to address these in an upcoming version.

6/2/2012 5:29:06 AM Reply with Quote

Is there any update on this issue? I'm having the same problem with nearly an identical setup. I'm also currently using the latest version of the client.

6/21/2012 6:07:40 AM Reply with Quote

Hi,
How can we enable mentioned xml logging in recent (latest available) version of Nefsis Professional (it's not available in Settings->General or any other place).

Yesterday and today we had strange connection problems (seems like Nefsis servers could firewall connections from our main IP (because connection from our second IP went smoothly at the same time!).
Of course those problems arised at worst possible moment - when our CEO wanted to make presentation for cooperants in Australia and India...

6/25/2012 8:55:13 AM Reply with Quote

Quote:
Originally posted by Tomasz Przewlucki 
Hi, How can we enable mentioned xml logging in recent (latest available) version of Nefsis Professional (it's not available in Settings->General or any other place). Yesterday and today we had strange connection problems (seems like Nefsis servers could firewall connections from our main IP (because connection from our second IP went smoothly at the same time!). Of course those problems arised at worst possible moment - when our CEO wanted to make presentation for cooperants in Australia and India...



Open up your Presence Client and select the ‘N’ and choose ‘Settings’

The settings dialog box will pop up.

Choose ‘Connection’ | Check the ‘XML Logging’ check box | Select OK.

File is located under the following directories as PC_XML.log

o Windows XP/2000: %userprofile%\Local Settings\Application Data\WiredRed
o Windows Vista/7: %userprofile%\AppData\Local\WiredRed

8/13/2012 5:15:32 AM Reply with Quote
nefsis_connopt.jpg 

As i wrote in previous post, in actual Nefsis version there is no such option in Settings/Connection...
I see you don't know your own software, so screenshot in attachement.

<< < > >>
Reply to this Thread

NEED HELP?

Europe:   +44 (0) 870 224 0415  (09:00 to 17:30 weekdays, GMT)